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Gather Media, Create the Main Project Folder and Subfolders
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In this context, an “asset” is a source material, 
such as an unedited video or audio file.

Place Source Material in Appropriate Folders
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Copy entire “PRIVATE” folder from memory card to “Video Assets” folder 
(within your “Main Project Folder” on your external hard drive). 

You’ll find a folder titled “PRIVATE” when you connect camera to computer and open the “CANON” disk.

=====>

(contains all video recordings)

Copying Video Files from Camera to Computer
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Select “Browse”, 
assign project location 
to “Premiere” folder 

in “Main Project Folder” 
on your external hard drive

=====>Name project
=====>Set location

Open Adobe Premiere, Start a New Project



5

Select the “Scratch Disks” tab.

Make sure all scratch disks point to your “Premiere” 
folder within your Main Project Folder.

Set the Location of “Scratch Disks” to your “Premiere” folder
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Select “File” > “New” > “New Sequence”

If you used a camera from the SF Cage, select the 
“AVCHD” preset folder and choose a preset that 
matches the frame size and frame rate of your source 
video footage. 

For instance, if you shot “FXP” at 30fps 
(frames per second), choose “(frames per second), choose “AVCHD 1080p30”.

If you don’t know the frame size and frame rate of your 
footage, select any “AVCHD” preset because once you 
bring a video clip to the timeline, Premiere, detecting 
that footage and sequence settings don’t match, will 
provide you with an opportunity to “change sequence 
settings” to better suit the video footage.

In most cases, if PIn most cases, if Premeire asks, you can select 
“change sequence settings”.

Create a New Sequence in Premiere
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Overview of Default Workspace
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1) File > Import…

2) Locate files within “Video Assets” folder and click “Import”

3) Imported files appear in Project panel

Import Files into Premiere
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Use yellow playhead to “scroll” through video. 
Press play button to watch clip.

Double click on icon next to name of video file. 
Video then appears in Source Monitor above.

Reviewing Footage in Source Monitor
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Source Monitor

A) Set time marker
B) Set “In” point
C) Set “Out” point
D) Go to “In” point
E) Go back a frame
F) Play

Location of playhead
(hrs:mins:secs:frames)

Total length of clip 
(or in-to-out)In to Out point 

(selection)

G) Go to “Out” point
H) Go forward a frame
I) Insert (into Timeline)
J) Overwrite (on Timeline)
K) Export frame

A B C I J KD E F G H

Reviewing Footage in Source Monitor (continued)
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<< video clip in timeline

This monitor (Program monitor) 
displays what’s happening in timeline

To put a video clip on Timeline:

Find video clip in Project panel,
click on icon next to file name 
(example name: “00001.MTS”) 
and drag/drop file on Timeline.

Another way:

Select file in PSelect file in Project panel,
Open file in Source monitor,
Select “Insert” button

drag/drop file 
onto Timeline

Getting Video Clips on the Timeline
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Constructing a Sequence
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drag edge of clip to right

clip is now shorter; try it!

If you have clips situated side by side in the timeline, trimming a clip 
will leave a gap between the clips equal to the amount you dragged.
If you want to remove the gap, select the area and press delete.

Other tools for trimming include: 
ripple, roll, slip and slide tools (all in tool menu) 

Hover over edge of clip (either side) using “Selection” tool (top of tool menu)

Notice: cursor changes shape, turns into a red bracket (not shown in images)

Now click down on clip and drag edge (right to shorten, left to lengthen)

Premiere lets you shorten and lengthen clips in the timeline.

Changing the Length of Clips
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Hold down “command” while moving clip 
and Premiere fills in the gap. Try it yourself.

Moving a clip from one position in the timeline 
to another produces a gap (in content).

no gap (adjacent clips move to left)

hold down “command” while moving

produces gap

moving clip from left to right

Premiere lets you freely move clips around in the timeline. 

Moving Clips Around in the Timeline
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Click on the clip (be it video or audio) at the point where you want the cut to be made.

The razor tool is used to cut a clip (in the timeline) into two separate clips. 

Cutting Clips in the Timeline
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When inserting a clip into the timeline, 
video and audio tracks are often linked.

To unlink video and audio tracks:

Right click on clip, select “Unlink” from pop-up menu.

“Unlinking” Video and Audio Clips
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1) Control click on clip in timeline

2) Select “Speed/Duration” from pop-up menu

A small window appears with options to:

- change speed in terms of percentage (20%, 50%, 200%, etc.)
- change speed in terms of duration (hrs:mins:sec:frames)
- reverse speed (to make clip play backwards)
- maintain au- maintain audio pitch (if audio is selected alongside video)
- ripple edit, shift trailing clips (try this one and see what happens)

Changing Speed/Duration and Reversing Playback
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Experiment with altering the values for 
position, scale, rotation and others.

Notice: “Effect Controls” tab opens in top left hand window

Effect Controls

Select the desired clip in the Timeline
Click on “Window” (top menu)
Select “Effect Controls” from list

You can change the position, scale, rotation and opacity of a video clip under the clip’s “Effect Controls” tab.

Effect Controls
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Find “Fast Color Corrector” effect 
inside the “Color Correction” folder 
(within “Video Effects” folder)

In this example, we’ll apply a 
Color Correcting video effect.

Then find the “Effects” tab 
(often in the lower left-hand panel)

If lost, go to “Window” > “Effects”

Applying effects to video or audio clips is easy!

First, identify the clip in the timeline to which you want to apply an effect.

Applying Effects to Video/Audio Clips (part 1)
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When you’ve located the effect you want to use, 
click on small icon next to the name of effect 
(in this case: “Fast Color Corrector”)

Click icon once and drag/drop effect onto clip

Then find clip’s “Effect Controls” panel 
(clip must be selected in timeline)

Notice effect listed under “Video Effects” 
(or “Audio Effects” in case of audio)

Time to alter effect’s parameters!
Doing so will allow you to see 

changes to the clip (so long as you 
are viewing the clip in the timeline)

Applying Effects to Video/Audio Clips (part 2)
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1. Selection Tool (keyboard shortcut = V)
This is the default tool and is used for common tasks in the timeline. To select the tool, either click the select 
button in the toolbox or press the V on the keyboard. To select a single clip or transition, click the clip or transi-
tion in the timeline. To select only the video or audio portion of a clip, hold down the Alt key while clicking the 
clip. To select multiple clips, hold down the Shift key while clicking each required clip. To select multiple adjacent 
clips, you can drag a selection rectangle (marquee) around all the desired clips.

2. Track Selection Tool (keyboard shortcut = A)
Select all clips from a given point on a particular track in the timeline. Position the pointer where you would like 
to start the selection and click. To select an entire track, position the mouse right at the beginning of a track. If 
you want to select multiple tracks, hold down the Shift key while clicking.

3. Ripple Edit Tool (keyboard shortcut = B)
Move an edit point and the rest of timeline moves the same amount to compensate.

4. Rolling Edit Tool (keyboard shortcut = N)
Move an eMove an edit point without affecting the rest of the timeline. The first (outgoing) clip is made shorter while the 
second (incoming) clip is made longer by the same amount, or vice versa.

5. Rate Stretch Tool (keyboard shortcut = X)
Change the duration of a clip while simultaneously adjusting the speed to compensate. 
Using rate stretch tool, reduction in length = increase in speed, increase in length = reduction in speed.

1

2

3

4

5

Tool Menu (part 1)
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1. Razor Tool (keyboard shortcut = C)
Cut a clip into two separate clips. Click on the clip at the point where you want the cut to be made.

2. Slip Edit Tool (keyboard shortcut = Y)
Adjust the in and out points of a clip at the same time by the same amount in the same direction (clip duration 
dœsn’t change).

3. Slide Tool (keyboard shortcut = U)
Moving a cMoving a clip left or right in the timeline while simultaneously adjusting other clips to compensate. 
Duration of clip you’re sliding stays the same. Durations of clips on either side will be automatically reduced or 
increased as required.

4. Pen Tool (keyboard shortcut = P)
The pen tool is used for creating control points (a.k.a. anchor points or keyframes).

5. Hand Tool (keyboard shortcut = H)
The hand tool is used to drag the area of the timeline visible in the sequence pane left and right.

6. Zoom 6. Zoom Tool (keyboard shortcut = Z)
The zoom tool is used to zoom into portions of the timeline.

1

2

3

4

5

6

Tool Menu (part 2)
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1) Title > New Title > Default Still

Here you can name the title
In most cases, you can press “OK” 

2) “New Title” dialog box appears

Creating titles in Premiere is similar to working 
with type tools in other Adobe design programs. 

The image in the background is not part of the title. 
Change the image by moving the playhead (on timeline). 
Toggle on/off the image via “Show Background Video” 
button at the top of title editing window (see pink circle).

3) Title editing window appears

You can treat a title just as 
would a video clip. Drag it 
onto the timeline (preferably 
on a different layer than your 
video clips) Try it yourself

4) Title appears in project panel

Creating Titles (Text)
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Premiere will display a progress indicator 
with an estimated rendering time. 

Rendering could take awhile, depending on the 
length of your sequence and how many transitions 
and effects the sequence contains.

To render the currently active sequence, 
choose “Sequence > Render Entire Work Area” 
from the menu bar.

Premiere will do it’s best to play back footage while you’re editing, 
but it may be doing so at 25% or 50% of the original resolution and 
only showing you the full resolution image when the video is paused 
(this depends on the Source Monitor preferences). 

This speeds up the editing process, but when you’re done editing, 
it’s good practice to review your video in full resolution before exporting.

YYou need to render your sequence to see it in full resolution (in Premiere), 
with all of the effects and transitions looking like they will in the final video, 

Sections of your video that require rendering are indicated 
by a red line above the video track area in the timeline.

Rendering is the process of pre-computing any transitions or effects that are needed for full-quality, real-time playback (in Premiere).

Rendering
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“Entire Sequence” 
To export all media in sequence, regardless of 
designated work area or IN/OUT points on timeline

“Sequence In/Out” 
To export ONLY content between 
IN and OUT marks on timeline (if any)

““Work Area” -
To ONLY export media within bounds of 
designated work area on timeline

“Custom” 
On timeline in Export Settings window, 
you can manually set IN/OUT points by 
click+dragging markers at beginning/end of timeline

5) Select a “Source Range”

4) Export Settings window appears

3) File > Export > Media…

1) Select the sequence you wish to export.
2) Make sure Sequence window is selected.

Exporting Your Sequence (part 1)
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Instructions on how to export a master file (the highest quality copy):

1) Under “Format”, choose “Quicktime”
2) Skip “Preset” and “Comments”
3) Next to “Output Name”, click on yellow text (to rename and save file to your drive)
4) Make sure that “Export Video” and “Export Audio” are selected (if applicable).
5) Under “Summary”, take note of the “Source” information, i.e. the size (ie, 1920x1080), 
        the frame rate (frames per second), and whether the video is progressive or interlaced.
6) With the “Video” tab selected, under “Video Codec”, choose “Apple ProRes 422 (HQ)”
7) Under “Basic Settings”, set Quality to 100. Make sure your width, height, and frame rate    
    match those in the “Summary” (under “Source”).
8) If interlaced video, “Field Type” should be “Lower”. If Progressive video, “Progressive”.
9) Set “Aspect Ratio” to “Square Pixel (1.0)”
10) Select “Render at Maximum Depth”. Longer exporting time, better image (optional).
11) 11) You will generally want to select “Use Maximum Render Quality”

Exporting Your Sequence (part 2: exporting a master quality file)
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Exporting Your Sequence (part 3: exporting for the web)



Lynda.com Tutorials 
(sign in with your MassArt username/password)

Adobe Premiere Pro CC Help
https://helpx.adobe.com/pdf/premiere_pro_reference.pdf

Adobe Premiere Discussion Forum 
https://forums.adobe.com/community/premiere

MeMedia College - Free Resources for Film and Digital Media Production
http://www.mediacollege.com/

Vimeo’s Video School
https://vimeo.com/blog/category/video-school

Larry Jordan’s Free Video Tutorials
https://larryjordan.com/free-tutorials/

Kino-Eye.com - documentary, new media, video arts and more
hhttp://kino-eye.com/

FilmSound -  learning space dedicated to the art of film sound design
http://www.filmsound.org/ 28

Resources for Further Study


